The Control Centre is fully operational and stable, with no further performance or access issues observed. All services are operating within expected parameters.
Our monitoring confirms that the mitigations implemented have been effective, and no recurrence of the issue has been detected.
We will continue to monitor the platform as part of standard operations. A full root cause analysis, including corrective and preventive actions, will be shared once our review is complete.
Posted Jun 26, 2026 - 09:27 UTC
Update
The Control Centre remains available and responsive, with no recurrence of earlier access issues.
Some minor performance degradation may still occur in specific areas, but overall service is operating within expected parameters.
We are continuing to monitor the platform and underlying services closely to maintain stability and quickly detect any changes. Further optimisation and hardening actions will follow based on this ongoing analysis.
We will provide the next update tomorrow.
Posted Jun 25, 2026 - 16:07 UTC
Monitoring
The Control Centre is now available and responsive, with access restored for affected users and overall service significantly improved. Our investigation indicates the issue stemmed from an infrastructure problem in a backend service, causing increased resource usage and intermittent unresponsiveness. Mitigations have been applied, and we are monitoring closely. We have identified the likely root cause and are working on a permanent fix. A full root cause analysis with corrective actions will follow once remediation is complete. We will share a further update once the permanent fix is in place or if anything changes.
Posted Jun 25, 2026 - 13:20 UTC
Investigating
We’re currently experiencing performance degradation in the Control Centre, including slow loading times and intermittent responsiveness. This behaviour has been observed across multiple environments. Our team is actively working to resolve the issue and restore normal performance as quickly as possible. We appreciate your patience and apologise for the disruption caused.