During periods of increased system demand, backend services may automatically scale as designed. In some circumstances though, these instances may be deployed on the same underlying host as an existing backend instance or alongside other services that place significant demand on available resources.
To improve infrastructure resilience and minimise the potential impact of resource contention, we are implementing a placement strategy that limits each host to a single backend API instance. This provides greater separation between backend services, helps distribute resource utilisation more evenly across the infrastructure, and reduces the potential for a single host to impact multiple production instances.
Posted Aug 28, 2026 - 11:12 UTC
Monitoring
We have identified an issue with our backend services and have implemented actions to mitigate. Performance has since returned to within acceptable levels and we are continuing to monitor the situation and work on a permanent fix.
Posted Aug 04, 2026 - 09:22 UTC
Investigating
We're currently investigating intermittent performance issues. Some users may experience slower response times when loading pages or running queries in Control Centre. We're monitoring closely and will post updates as we learn more.